Microsoft has confirmed that all storage clusters are now back online and customer impact has been mitigated. The issue has been resolved, and we are continuing to monitor the environment closely.
Posted Nov 06, 2025 - 06:58 UTC
Update
Update from Microsoft:
We have recovered one of the impacted storage scale units, and customers are beginning to see signs of recovery. We expect another scale unit to recover within the next 30 minutes. Recovery efforts are ongoing and progressing in parallel across other impacted storage scale units. We anticipate recovery on these units in approximately 2 hours.
Posted Nov 06, 2025 - 02:03 UTC
Identified
We are currently experiencing service disruptions in the West Europe region due to a thermal event affecting Microsoft datacenters, which is impacting multiple areas of our platform. Our team is actively working with Microsoft and monitoring the situation closely to restore full functionality as quickly as possible. We will provide updates as soon as more information becomes available or a resolution is in place, and we appreciate your patience and understanding during this time.